Appcelerator Q&A Archive

Search the archived Community Support

Hi All,

We are pleased to announce the general availability of SDK 5.1.0/Studio 4.4.0! The major updates include:

  • Support Node.js 4.2.x, 4.1.x
  • Support for iOS Slicing (App Thinning)
  • Support for iOS 3D Touch ("Peek and Pop" and "Quick Actions")
  • Safari Dialog Module (SFSafariViewController) for iOS
  • Support for Android 6.0 Marshmallow Runtime Permissions
  • Android Material Design: CardView and Reveal Effect
  • More API Parity on Windows (Ti.Buffer, Ti.Contacts etc.)
  • Significant bug fixes and feature additions for Android, Windows and iOS.

For more information, read the SDK release notes. To enable or disable iOS app thinning, please follow this guide.
You can checkout the new iOS9 3d touch sample app here and and a 5.1.0 sample app follows after the weekend.

To install the set of updates, launch Appcelerator Studio. It will install the updates automatically. From the command line:

[sudo] npm install -g appcelerator
appc setup

As always, file bugs and issues in the "AC" project in JIRA.

We also like to give a shoutout to Ben Bahrenberg, Manoj Kumar, Manual Lehner from the community who contributed and helped us tremendously in our 5.1.0 efforts!

2015, November 21st by CheeKiat in Q&A 2015

Answers

  • @CheeKiat When using the new build Im experiencing an issue with my list view, loosing image from the list items. Its very sporadic. Using 5.0.2 GA and the problem doesnt occur.

    2015, November 21st by peterladis
  • @peterladis Can you file a ticket with regards to this? Are you using remote or local images in your list view? it'll be good if you could give us a reproducible case. Appreciate it.

    2015, November 21st by CheeKiat
  • @CheeKiat Yeah i already filed in JIRA also. They are local images. I added screen shots also.

    2015, November 21st by peterladis
  • @CheeKiat said:

    Support Node.js 4.2, 4.1.x

    Node 4.2 ? Not 4.2.2 (last LTS version) ?

    2015, November 21st by botmaster
  • @CheeKiat
    I can not make Studio work after update, nor Run nor Debug. This error everywhere:

    com.appcelerator.titanium.core.user.ITitaniumUserManager.getSignedInUser()Lcom/appcelerator/titanium/core/user/ITitaniumUser;
    
    2015, November 21st by falko
  • @CheeKiat
    2015-11-24T19:23:06.112Z | ERROR | The registry server is currently unavailable.

    What is the solution?

    2015, November 24th by stefansgorzaly
  • @falko This is now addressed in an update to 4.4.0.

    2015, November 25th by bingomar
  • @stefansgorzaly Can you print the results after passing -l debug at the end of whatever command you are running?

    2015, November 25th by bingomar
  • @bingomar What update version should I be looking for? I'm getting same error as @falko running Studio 4.4.0.201511241829, which I just updated this morning.

    2015, November 25th by j2abro
  • @bingomar For this problem i found the solution. You can find it in another thread.

    But since CLI 5.1.0 and the required update of SDK platform i can't deploy to Android devices. :-(

    2015, November 25th by stefansgorzaly
  • @stefansgorzaly Yep also broke android builds for me.

    It copies it over to the handset, but then won't launch.

    Why the heck is it that every change to Titanium massively breaks Android.

    When you do a release guys, link to some instructions on how to revert back to the last build - these issues happen way too often.

    2015, November 26th by Rick132
  • @CheeKiat The Android CardView looks great. Any ideas what will be the best way to make something similar in iOS with best code re-use so it looks and act similar? I'm thinking of making them manually for iOS.

    2015, November 27th by dimovdanielyahoo.com
  • @Rick132 @stefansgorzaly I've got the same issue.

    I notice that:

    • I can deploy the app on Genymotion simulator (Nexus 5 image with Android Lollipop 5.1.1) with no issue;
    • I can create the apk for the distribution:
      ** When I try to install it on my phone (LG G3 d855) with Android Marshmallow it crashes;
      ** When I try to install it on nexus 7 (2012) with Android Lollipop 5.1.1 it works with no issue;
    • When I try to deploy the app on my phone with Android Marshmallow it crashes;

    Have you got a behaviuor like me?

    2015, November 27th by AlbWebbergate
  • @CheeKiat Any updates on this thread. This error is painful and I'm not seeing a workaround.

    2015, November 30th by j2abro
  • @falko Reinstalling Studio over my existing installation solved this problem for me, while maintaining by configuration settings.

    2015, December 1st by j2abro
  • @dimovdanielyahoo.com

    hey, I was wondering, i updated through Appcelerator Studio and SDK 5.1.0 did not popup in my tiapp. Then i used the terminal commands as in the post in this thread, and it worked.

    I can remember from some time ago that the studio would also update the SDK?

    Also, when i type titanium -v into terminal, it states 5.0.4. Is this namespace still used? I seem to have some duplication issues ever since the studio change.

    My npm list -g states i have appcelerator@4.2.2 but also titanium@5.0.4 and even titanium-code-processor@1.1.1.

    Finally im getting an "invalid" warning being:
    npm ERR! invalid: chalk@0.5.0 /usr/local/lib/node_modules/appcelerator/node_modules/chalk

    Can any1 shine some light on what to use and what to discard?

    2015, December 2nd by Bert243
  • @CheeKiat

    would be great if it worked, yet again another update costs me days of trying to fix...

    [ERROR] : tunneling socket could not be established, cause=getaddrinfo ENOTFOUND null

    2015, December 3rd by darrenbrowngecom
  • @AlbWebbergate Are you using modules for Android? I was having weird issues with Android since this update too (as you described) and found out that a module was causing it (drawer). I updated the module and now everything works fine. Hope it helps.

    2015, December 7th by Pablo
  • @Bert243 I'm getting this also "npm ERR! invalid: chalk@0.5.0 /usr/local/lib/node_modules/appcelerator/node_modules/chalk"